Knowledge Base


Advertisement


Community Forums

Does it matter which version of FrostWire I use?

Follow
Yes. Using the most recent version of FrostWire allows users to enjoy the best program functionality. Bugs reported in older versions have been fixed for our latest version. Any users with FrostWire 4 or earlier MUST update. FrostWire versions 4.x and earlier are no longer supported.

To download FrostWire, please visit www.frostwire.com. The FrostWire program will automatically notify you if there is a new version available.
Have more questions? Submit a request

Comments

Powered by Zendesk